re = /\/\d+/m
str = 'http://host.name/v2/type/44/things
http://host.name/v2/type/44
http://host.name/v2/type/30d-hot'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end