# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/APDNUDES_F20[0-9]{2}_((?:[A-Za-z]+-?)*-in-(?:[A-Za-z]+-?)*)_[P|V][0-9]+(\.[\w]{3,4})?/${1}${2}/gm;t' <<< "APDNUDES_F2013_Sammi-Tye-in-Beauty_V190522172041.mp4
APDNUDES_F2013_Sammi-Tye-in-Classic-Curves_V190522161615.mp4
APDNUDES_F2013_Sammi-Tye-in-Classy-Erotica_V190522173336.mp4
APDNUDES_F2013_Sammi-Tye-in-Classy-Erotica_V190522173336
"