// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)APDNUDES_F20[0-9]{2}_((?:[A-Za-z]+-?)*-in-(?:[A-Za-z]+-?)*)_[P|V][0-9]+(\.[\w]{3,4})?").unwrap();
let string = "APDNUDES_F2013_Sammi-Tye-in-Beauty_V190522172041.mp4
APDNUDES_F2013_Sammi-Tye-in-Classic-Curves_V190522161615.mp4
APDNUDES_F2013_Sammi-Tye-in-Classy-Erotica_V190522173336.mp4
APDNUDES_F2013_Sammi-Tye-in-Classy-Erotica_V190522173336
";
let substitution = "${1}${2}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}