use strict;
my $str = '25
25 a
25b
25-ab
12-14
1
9
21
1a
121 b
25A
25 a
1 a1
1a1
12ab12
0
b
0a
00a
a a
00 a
13àâäèéêë
';
my $regex = qr/^[1-9]\d*(?:[ -]?(?:[a-zA-Z]+|[1-9]\d*))?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}