$re = '/^[1-9]\d*(?:[ -]?(?:[a-zA-Z]+|[1-9]\d*))?$/m';
$str = '25
25 a
25b
25-ab
12-14
1
9
21
1a
121 b
25A
25 a
1 a1
1a1
12ab12
0
b
0a
00a
a a
00 a
13àâäèéêë
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);