#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "_thumb(@[2-3]x)?\.jpg"
Local $sString = "grwior_thumb.jpg" & @CRLF & _
"grwior.jpg" & @CRLF & _
"vuoetrjrt_thumb@2x.jpg" & @CRLF & _
"vuoetrjrt.jpg" & @CRLF & _
"hafiruwhf_thumb.jpg" & @CRLF & _
"hafiruwhf_thumb@2x.jpg" & @CRLF & _
"hafiruwhf_thumb@3x.jpg" & @CRLF & _
"hafiruwhf.jpg" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")