# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"_thumb(@[2-3]x)?\.jpg"
test_str = ("grwior_thumb.jpg\n"
"grwior.jpg\n"
"vuoetrjrt_thumb@2x.jpg\n"
"vuoetrjrt.jpg\n"
"hafiruwhf_thumb.jpg\n"
"hafiruwhf_thumb@2x.jpg\n"
"hafiruwhf_thumb@3x.jpg\n"
"hafiruwhf.jpg\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.