$re = '/(?s)^.+?(?=C700\d*(?=\s))/miu';
$str = 'DFGC
2836 -07-0411B
IMUD - DHI211 (MOOYEHBF P/
SHDUF)
C7000039694 (PD MOFIBD PODF
BAOJFD) ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);