using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<p>)(.*) (?=</p>)";
string input = @"
<p> Праздничную иллюминацию в Липецке прежде традиционно отключали 15 января. Однако в этом году она будет работать до конца месяца, соответственно дольше обычного жители областного центра смогут любоваться световыми арт-объектами и нарядными новогодними елками. Такое решение принял глава города Сергей Иванов.Как сообщил председатель департамента дорожного хозяйства и благоустройства Алексей Бахтин, идея навеяна самой нынешней зимой. Яркие краски светового оформления города подчеркнут красоту заснеженных улиц и продлят праздничное настроение липчанам. </p>
<t> В администрации Липецка - незаурядная отставка: уходит управделами Виктор Ивлев, житель Тербунов, которого в мэрию привел его земляк Сергей Иванов, ставший главой города волей Липецкого горсовета в декабре 2015 года. Последним местом работы Виктора Ивлева в Тербунах была должность председателя районной территориальной избирательной комиссии.
- 14 января станет последним днем работы Виктора Денисовича. Он принял такое решение по состоянию здоровья. Недавно он перенес тяжелую операцию на сердце и решил уйти с должности на пенсию, - прокомментировал GOROD48 циркулирующие слухи об отставке управделами мэрии глава Липецка Сергей Иванов. </t>(?<=<title>)(.*)(?=</title>)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}