# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([^\p{Pd}]+)(\p{Pd})(.*)$/$1-$3/gm;t' <<< "GBI - AVP SALES"