package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^\p{Pd}]+)(\p{Pd})(.*)$`)
var str = `GBI - AVP SALES`
var substitution = "$1-$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}