const regex = /^([^\p{Pd}]+)(\p{Pd})(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^\\p{Pd}]+)(\\p{Pd})(.*)$', 'gm')
const str = `GBI - AVP SALES`;
const subst = `$1-$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);