$re = '/-(.*?)_/';
$str = 'adapter-UDP02_sistem10_a.log';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);