package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)`[^`]*`(*SKIP)(*F)|\R{2}`)
var str = `Some random text...
text after break
haha text
\`Hey,
here is some text!
and here is the end =)\`
here is text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}