#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([A-Z][a-z]+|[0-9]+|[A-Z]+?(?=[A-Z][a-z]|[0-9]|$))"
Local $sString = "ThisIsATest" & @CRLF & _
"TestTest" & @CRLF & _
"ATMMachine" & @CRLF & _
"NewATM" & @CRLF & _
"NewATMMachine" & @CRLF & _
"TestTest123123" & @CRLF & _
"NewATM09" & @CRLF & _
"New99ATM" & @CRLF & _
"NewATMMachine09" & @CRLF & _
"99ATM"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")