import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z][a-z]+|[0-9]+|[A-Z]+?(?=[A-Z][a-z]|[0-9]|$))";
final String string = "ThisIsATest\n"
+ "TestTest\n"
+ "ATMMachine\n"
+ "NewATM\n"
+ "NewATMMachine\n"
+ "TestTest123123\n"
+ "NewATM09\n"
+ "New99ATM\n"
+ "NewATMMachine09\n"
+ "99ATM";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}