package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bUA\s?\d{2}\s?\d{6}\s?\d{19}\b`)
var str = `UA 19 300346 0000000000029242108
UA193003460000000000029242108
UA 193003460000000000029242108
UA293003560000000000029112108
UA083001260000000000029243308
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}