import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bUA\\s?\\d{2}\\s?\\d{6}\\s?\\d{19}\\b";
final String string = "UA 19 300346 0000000000029242108\n"
+ "UA193003460000000000029242108\n"
+ "UA 193003460000000000029242108\n"
+ "UA293003560000000000029112108\n"
+ "UA083001260000000000029243308\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}