using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-z\d]|(?<![-_])(?<!^)[-_](?!$)){2,36}$";
string input = @"abcdefghijklmnop_stuvwx-z0123456789
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}