$re = '/^([a-z\d]|(?<![-_])(?<!^)[-_](?!$)){2,36}$/';
$str = 'abcdefghijklmnop_stuvwx-z0123456789
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);