import Foundation
let pattern = #"^([a-z\d]|(?<![-_])(?<!^)[-_](?!$)){2,36}$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
abcdefghijklmnop_stuvwx-z0123456789
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}