import Foundation
let pattern = #"(https?:\/\/)?(www\.)?(t\.me|telegram\.dog|telegram\.me)\/[A-Za-z0-9](?:[A-Za-z0-9_]{2,30}[A-Za-z0-9])?\/?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
t.me/myAlfredo
t.me/_myAlfredo
https://telegram.dog/myAlfredo_
http://telegram.me/my_Alfredo/
https://www.t.me/myAlfredofghgffgfhffbgfbcvbcvbcvfgfg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)