const regex = new RegExp('^(?!.*([\\'-]).*\\1)(?!.*[\\'-](?:[a-z]|$))(?!.*(?<=[^\\'-])[A-Z])[A-Z][A-Za-z\\'-]{0,31}$', 'gm')
const str = `Mc'Tiray-Jay
Mc'Tiray-JJay
Mc'Tiray-jJay
Mc'tiray-Jay
Mc'Tiray-Jay
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}