import Foundation
let pattern = #"^(?!.*(['-]).*\1)(?!.*['-](?:[a-z]|$))(?!.*(?<=[^'-])[A-Z])[A-Z][A-Za-z'-]{0,31}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Mc'Tiray-Jay
Mc'Tiray-JJay
Mc'Tiray-jJay
Mc'tiray-Jay
Mc'Tiray-Jay
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)