using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<=^)|(?<=\.))\s*(?![^.]*Bull).*?((?=$)|(?=\.))";
string input = @"This is a Dog. This is Cat. This is a Bull. This is a Cow";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}