$re = '/^C+$/m';
$str = 'ABC
ACB
CAB
CAC
CCC CCC
CCC
CC
C
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);