import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<category id=\"(\\d+)\"><name>(.*?)<\\/name><short><\\/short><\\/category>";
final String string = "<category id=\"1\"><name>Мужские куртки</name><short></short></category>\n"
+ "<category id=\"2\"><name>Мужские брюки</name><short></short></category>\n"
+ "<category id=\"3\"><name>Мужские портянки</name><short></short></category>";
final String subst = "<category id=\"$1\"><name>$2</name><short>$2</short></category>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}