const regex = /<category id="(\d+)"><name>(.*?)<\/name><short><\/short><\/category>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<category id="(\\d+)"><name>(.*?)<\\\/name><short><\\\/short><\\\/category>', 'gm')
const str = `<category id="1"><name>Мужские куртки</name><short></short></category>
<category id="2"><name>Мужские брюки</name><short></short></category>
<category id="3"><name>Мужские портянки</name><short></short></category>`;
const subst = `<category id="$1"><name>$2</name><short>$2</short></category>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);