# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\d)[.](?=\d{3}[.])//gm;t' <<< "[1] \"AA.8.BB.CCCC\" \"2017\" \"3.166.5\" \"3.080.2\" \"68\" \"162.6\"
[7] \"185.223.632.4\" \"500.332.1\" "