const regex = /\b(x(?1)y|(?<=x)(?=y))\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(x(?1)y|(?<=x)(?=y))\\b', 'gm')
const str = `xy -> valid
xxyy -> valid
xxxyyy -> valid
xyy -> not valid
xxy -> not valid`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}