re = /\b(x(?1)y|(?<=x)(?=y))\b/m
str = 'xy -> valid
xxyy -> valid
xxxyyy -> valid
xyy -> not valid
xxy -> not valid'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end