use strict;
my $str = '“ ”9 9s asd sa das d as d asd as dsa sad asd as da sdas d “ ” ';
my $regex = qr/&.*?\;/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";