$re = '/&.*?\;/m';
$str = '“ ”9 9s asd sa das d as d asd as dsa sad asd as da sdas d “ ” ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;