re = /&.*?\;/m
str = '“ ”9 9s asd sa das d as d asd as dsa sad asd as da sdas d “ ” '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result