$re = '/(?<!\\\\)(?:\\\\{2})*\K\\\\code/m';
$str = '\\\\\\code
\\\\code
\\code';
$subst = "1234";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;