package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((.+[ ][:][ ].+)|(.+[ ][:][ ])|([ ][:][ ].+)|(.+))$`)
var str = `Cooper Koch : Erik Menéndez
Nicholas Alexander Chavez :
Nathan Lane
: Dominick Dunne
...
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}