package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\[[^]]+\].+`)
var str = `[FIX] [SDK-974] validate head commit format
Commit 2
Commit 3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}