re = /^\[[^]]+\].+/m
str = '[FIX] [SDK-974] validate head commit format
Commit 2
Commit 3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end