$re = '/^(?:(?!RSBO|RRABO|RSISTA0).)*$/m';
$str = 'RSBO
FOORSBO
RSBOFOO
FOORSBOBAR
RRABO
FOORRABO
RRABOFOO
FOORRABOBAR
RSISTA0
FOORSISTA0
RSISTA0FOO
FOORSISTA0BAR
THIS_MATCHES';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);