import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[^,]*,){2}\\K[^,\\n]+(?=(?:,[^,\\n]*){3},4[0-9][0-9],)";
final String string = "field1,field2,Name 1,field4,field5,field6,101, field8\n"
+ "field1,field2,Name 2,field4,field5,field6,499, field8\n"
+ "field1,field2,Name 3,field4,field5,field6,500, field8\n"
+ "field1,field2,Name 4,field4,field5,field6,4214.00, field8";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}