import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "technology .+ <!-- -->";
final String string = "technology capture group examples ending in comments <!-- -->\n"
+ "technology groups are pretty simple to capture, imo, as long as they end with <!-- --> \n"
+ "technology groups should remain consistent, if they don't end in <!-- --> it gets weird";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}