$re = '/^(?:.*\[.*\].*|.*(?!убит|отошел).*)$/m';
$str = 'Shoorik отошел
[G] Shoorik я отошел
текст должен выделяться
он был убит а
был убит 123
был убит
и этот текст тоже
[L] был убит
[G] просто текст
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);