# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?<!value)\":\s\"|':\su')\b[a-fA-F\d]{32}"
test_str = ("\"value\": \"ef51be4506d7d287abc8c26ea6c495f6\", \"u_jira_status\": \"\", \"u_quarter_closed\": \"\", \"file_hash\": \"ef51be4506d7d287abc8c26ea6c495f6\", \"escalation\": \"0\", \"upon_approval\": \"proceed\", \"correlation_id\": \"ef51be4506d7d287abc8c26ea6c495f6\", \"cyber_kill_change\": \"ef51be4506d7d287abc8c26ea6c495f6\", \"sys_id\": \"ef51be4506d7d287abc8c26ea6c495f6\", \"u_business_service\": \"\", \"destination_ip\": \"ef51be4506d7d287abc8c26ea6c495f6\", u'valuee': u'9db92f08db4f951423c87d84f39619ef'\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.