import re
regex = re.compile(r"{[^{}]*?\banimal(\w+)\[name=\"[^\s\"*]*\"]", flags=re.MULTILINE)
test_str = ("Animals {\n"
" idAnimal\n"
" nameAnimal\n"
" animal456jlk165ut[name=\"Dalty\"]\n"
" animal6ljkj[name=\"Moon\"]\n\n"
"}\n\n"
"Animals {\n"
" idAnimal\n"
" nameAnimal\n"
" animalk45lil69lhfr5942lk[name=\"Jazz\"]\n"
" animal6ljkjh[name=\"Pinky\"]\n"
" animal595s422d1252g55[name=\"Steven\"]\n"
" animalko5854hg[name=\"David\"]\n"
" animalko5854hg[name=\"Oty\"]\n"
" animalko5854hg[name=\"Dan\"]\n"
"}\n\n"
"Animals {\n"
" idAnimal\n"
" nameAnimal\n"
" animalko5854hg[name=\"Jazz\"]\n"
" animal6ljkjh[name=\"Pinky\"]\n"
" animal595s422d1252g55[name=\"Steven\"]\n"
" animalko5854hg[name=\"David\"]\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")