re = /^(?:.*(ABC))?.*/m
str = 'precedingstringwithundefinedlenghtABCsubsequentstringwithundefinedlength
precedingstringwithundefinedlenghtsubsequentstringwithundefinedlength'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end