using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[ -~\n\r\tâââ]*$";
string input = @"checked
checked
checked
checked
checked
checked
checked
checked
checked
checked
checked
checked
checked
checked
checked
checked
471
819
855
875
947
1079
1263
1634
checked
checked
checked
checked
2585
2615
checked
checked
2710
2740
checked
checked
3078
3207
3297
3327
checked
checked
3357
3462
3492
3552
3642
3885";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}