# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(([0-1][0-9]|2[0-3]):[0-5][0-9](:[0-5][0-9])?)$"
test_str = ("17:30\n"
"24:00\n"
"19:11:07\n"
"00:00\n"
"00:00:00\n"
"23:59\n"
"5:50\n"
"29:01:02\n"
"01:02:03\n"
"00:00:59\n"
"00:00:60\n"
"60:60:60")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.