re = /^(([0-1][0-9]|2[0-3]):[0-5][0-9](:[0-5][0-9])?)$/m
str = '17:30
24:00
19:11:07
00:00
00:00:00
23:59
5:50
29:01:02
01:02:03
00:00:59
00:00:60
60:60:60'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end