#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https?:\/\/[A-Za-z0-9:/.]+(?:([ ,;])https?:\/\/[A-Za-z0-9:/.]+(?:\1[A-Za-z0-9:/.]+)*)?$"
Local $sString = "e.g this should match as it only uses one type of special character (semi-colon): " & @CRLF & _
"" & @CRLF & _
"https://hello.com/example1;https://hello.com.com/example2;https://hello.com.com/example3" & @CRLF & _
"" & @CRLF & _
"This should fail as it mixes two types of special characters (space and semi-colon)" & @CRLF & _
"" & @CRLF & _
"https://hello.com/example1; https://hello.com.com/example2 ;https://hello.com.com/example3" & @CRLF & _
"" & @CRLF & _
"https://hello.com/example1" & @CRLF & _
"" & @CRLF & _
"test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")