re = /^https?:\/\/[A-Za-z0-9:\/.]+(?:([ ,;])https?:\/\/[A-Za-z0-9:\/.]+(?:\1[A-Za-z0-9:\/.]+)*)?$/m
str = 'e.g this should match as it only uses one type of special character (semi-colon):
https://hello.com/example1;https://hello.com.com/example2;https://hello.com.com/example3
This should fail as it mixes two types of special characters (space and semi-colon)
https://hello.com/example1; https://hello.com.com/example2 ;https://hello.com.com/example3
https://hello.com/example1
test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end